Форум ModelldepO  

Вернуться   Форум ModelldepO > Моделизм > Макеты > Наши стройки
Наши стройки Строительство макетов в процессе

Ответ
 
Опции темы Опции просмотра
Старый 02.04.2019, 20:18   #26
laba
Местный
 
Аватар для laba
 
Регистрация: 06.03.2009
Адрес: Питер
Сообщений: 3,585
Сказал(а) 'не согласен(а)'!: 9
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 6,642
Поблагодарили 4,652 раз(а) в 1,766 сообщениях
Репутация: репутация неоспорима (4920)
По умолчанию

Греется-греется.......
оффтопик
__________________
HO, цифра, OpenDCC, S-88N, OpenCar, BiDiB
С приветом из подземки!!!
laba вне форума   Вверх
Старый 02.04.2019, 20:53   #27
Pooh
Садовод
 
Аватар для Pooh
 
Регистрация: 02.01.2008
Адрес: Москва
Сообщений: 1,178
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 14 раз(а) в 10 сообщениях
Сказал(а) спасибо: 661
Поблагодарили 2,252 раз(а) в 572 сообщениях
Репутация: репутация неоспорима (2291)
По умолчанию

Цитата:
Сообщение от laba Посмотреть сообщение
Не поплавилось конечно, но нагрев был.
Нагрев был не потому, что провод смотан и там какие-то индукции вылезают, а потому, что не было свободного движения воздуха для охлаждения поверхности. Собственно, исключительно ради этого и рекомендуют разматывать, но допустимый нагрев изоляции в ~65гр (рукой это взять нельзя) тоже в общем-то никто не отменял.
Pooh на форуме   Вверх
Пользователь сказал cпасибо:
Старый 03.04.2019, 01:02   #28
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от IChibrik Посмотреть сообщение
включите пылесос откуда была снята эта катушка, не разматывая ее
Дык в пылесосе катушка провода закрыта корпусом. Отсюда два дополнительных фактора: отсутствие охлаждения и нагрев от двигателя. Причём рассеиваемая мощность двигателя (те же 1500Вт) вызывает на порядки больший нагрев, чем протекающий по проводу ток (7Ах7Ах1Ом=50Вт, один Ом - это для упрощения, на самом деле намного меньше).

Включал я и пылесос в розетку на макете, ощутимо не успевала нагреться - свободное охлаждение плюс наполовину размотана.
Eprinter вне форума   Вверх
Старый 15.04.2019, 16:10   #29
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Декодер получился на 515% от задуманного первоначально, решил, что и модули ОС осилю
Спасибо огромное Алексею, очень вовремя опубликовал свои разработки, а это уже 90% готовой работы. Поизучал и взял за основу вот этот вариант, дополнив элементами группового модуля.

Получился гибрид - 8 датчиков считываются ардуиной напрямую, ещё 32 через МСР23017, индикацию оставил 595, их есть у нас много. На самом деле можно слегка подправить код и получить любую другую комбинацию, просто у меня уже стоят 5 фидбэков (адреса 1-5) и есть потребность добрать до 80 токовых участков (6-10). А следующая группа (модули 11-20) пойдёт уже под датчики положения стрелок и всевозможные пульты.

Слева подключаются токовые участки, общий контакт один. Выше 595 для подключенных к плате датчиков, правее шлейф на удалённую плату индикации. Справа, под модулем МАХ485, розетки RJ12 R-BUS. В центре (ниже Наночки) разъём I2C для удалённых датчиков.



Вид с изнанки:



Датчики спаяны по этой схеме, красным указан диод Шоттки, о нём позже:



И ещё один ракурс главной платы:



Фото с коллегой:



Общий план, справа прикрученная плата индикации, а также видны модули МСР:




Плата индикации получилась весьма недурственно, на мой взгляд, хоть и макетка:




Модули МСР пока в таком виде, приедут диодные мостики, спаяю платы и подключу:



Про диоды в мостах. Тестировал от станции МДпрог пару DB207 и PC817, работали нормально, может ток нужен был чуть поболя, чем минимальный. Спаял плату, подключил, начал править программу, естественно понадобилась зетка. И тут конфуз - при включении начиналось частое моргание, то сработка, то нет. Ну, думаю, не угадал я со сладкой парочкой, придётся добавить третьего не лишнего и впаял диоды, чтобы повысить чувствительность. Включаю - опять свистопляска...

Догадался посмотреть лог.анализатором, что там на рельсах:



Оказывается, зетка филонит и делает пропуски, постоянной времени RC на выходе оптопары видимо не хватает их сгладить. Но почему модули от МД не моргают? Переворачиваю сигнал на рельсах, и картина меняется - модуль на ардуине дышит ровно, заморгали FB2. Естественно, после первой же команды, отправленной на зетку, проблема уходит, паузы между ДСС командами резко уменьшаются. Так что диоды потом выпаяю, лучше увеличить резистор подтяжки к плюсу, или забить.

Скетч прилагается. Адрес самого модуля 6, плат расширения с 7 по 10, но можно поиграться.
Вложения:
Тип файла: zip R-BUS-NANO-40.zip (3.3 Кб, 11 просмотров)
Eprinter вне форума   Вверх
4 пользователя(ей) сказали cпасибо:
Старый 15.04.2019, 16:54   #30
Alexmit
Местный
 
Регистрация: 29.06.2010
Адрес: Москва
Сообщений: 1,719
Сказал(а) 'не согласен(а)'!: 3
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 550
Поблагодарили 1,633 раз(а) в 942 сообщениях
Репутация: обеспечил(а) себе прекрасное будущее (1633)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Догадался посмотреть лог.анализатором, что там на рельсах:
А если в z21 отключить Railcom?

Но я предпочитаю разбираться с этой проблемой "железно", или используя местный CD1 (нужна оптронная развязка),
или собственный вариант #62 (убрать выходной транзистор и програмно инвертировать вход модуля ОС)
Alexmit вне форума   Вверх
Пользователь сказал cпасибо:
Старый 16.04.2019, 00:30   #31
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от Alexmit Посмотреть сообщение
А если в z21 отключить Railcom?
У меня z21start, вряд ли он есть на борту
Мне нужно было общую шину с рельс паять не к анодам оптопар, а к катодам, как это подключено на всех моих модулях от МД. Тогда в паузы между командами ток не будет пропадать, работали бы синфазно. Сейчас перепаивать неохота, куча мелких деталей навесным монтажом.
Проще все 5 FB2 переключить, всего-то 80 винтиков отдать, проводочки переставить и снова зажать, плюс ещё два винтика, перевернуть шину на зетке
Ну а на участках с разворотной петли этот эффект уже не повторится - когда поедет хоть один лок, паузы становятся короткими и RC цепочка вполне справляется.

Вдогонку к фоточкам скрин, сверху что кажет зетка, посередине пакет с COM-порта FB2, видны разные показания с модуля 6:
Eprinter вне форума   Вверх
Пользователь сказал cпасибо:
Старый 16.04.2019, 20:01   #32
Alexmit
Местный
 
Регистрация: 29.06.2010
Адрес: Москва
Сообщений: 1,719
Сказал(а) 'не согласен(а)'!: 3
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 550
Поблагодарили 1,633 раз(а) в 942 сообщениях
Репутация: обеспечил(а) себе прекрасное будущее (1633)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Мне нужно было общую шину с рельс паять не к анодам оптопар, а к катодам, как это подключено на всех моих модулях от МД.
Не надо жадничать, надо ставить 814.
Цитата:
Сообщение от Eprinter Посмотреть сообщение
Тогда в паузы между командами ток не будет пропадать, работали бы синфазно.
Если это действительно паузы под райлком, то там напряжение снимается совсем.

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Вдогонку к фоточкам скрин, сверху что кажет зетка, посередине пакет с COM-порта FB2, видны разные показания с модуля 6:
Спасибо за картинку.
В Logic полистайте вправо. Может дальше будут совпадать.
Alexmit вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 00:26   #33
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от Alexmit Посмотреть сообщение
Не надо жадничать, надо ставить 814.
Вау, я и не знал о такой! Спасибо, запомнил на будущее

Цитата:
Сообщение от Alexmit Посмотреть сообщение
Если это действительно паузы под райлком, то там напряжение снимается совсем.
Судя по тому, что при смене полярности новый модуль перестаёт моргать, но начинают хором дёргаться старые, это не райлком. Да и пропадают паузы, как только я сдвину колёсико мультимауса.

ПС Сделал скрин, у меня как раз два канала с опторазвязкой предусмотрены:




Цитата:
Сообщение от Alexmit Посмотреть сообщение
Может дальше будут совпадать.
Конечно будут. Только Рокрэйлу от этого легче не будет

Уже решил, поменяю местами провода на старых модулях и сменю полярность, а на будущее возьму за стандарт общий провод с рельс сажать на аноды. У меня этих 817-х сотня лежит, куда их ещё, в таком количестве
Eprinter вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 09:17   #34
Alexmit
Местный
 
Регистрация: 29.06.2010
Адрес: Москва
Сообщений: 1,719
Сказал(а) 'не согласен(а)'!: 3
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 550
Поблагодарили 1,633 раз(а) в 942 сообщениях
Репутация: обеспечил(а) себе прекрасное будущее (1633)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Конечно будут. Только Рокрэйлу от этого легче не будет
#30
Alexmit вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 09:40   #35
Saddam
Местный
 
Регистрация: 06.09.2013
Адрес: Челябинская область
Сообщений: 3,279
Сказал(а) 'не согласен(а)'!: 20
Сказали 'не согласен'! 27 раз(а) в 21 сообщениях
Сказал(а) спасибо: 2,185
Поблагодарили 3,628 раз(а) в 1,344 сообщениях
Репутация: репутация неоспорима (3627)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
У меня z21start, вряд ли он есть на борту
Есть , отключите и проверьте паузы уйдут.
Saddam вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 10:49   #36
xu56857
Пользователь
 
Аватар для xu56857
 
Регистрация: 02.02.2015
Адрес: Москва
Сообщений: 597
Сказал(а) 'не согласен(а)'!: 5
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 2,539
Поблагодарили 2,264 раз(а) в 399 сообщениях
Репутация: репутация неоспорима (2279)
По умолчанию

817 - оптопары в токовых датчиках работают вполне нормально. У Вас на схеме на оптопару после диодов резистор 10 Ом? Маловато будет, возможны ложные срабатывания.
xu56857 вне форума   Вверх
2 пользователя(ей) сказали cпасибо:
Старый 17.04.2019, 10:56   #37
shalex
Местный
 
Регистрация: 08.07.2015
Адрес: Ступино
Сообщений: 2,394
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 3 раз(а) в 2 сообщениях
Сказал(а) спасибо: 3,824
Поблагодарили 2,280 раз(а) в 896 сообщениях
Репутация: репутация неоспорима (2281)
По умолчанию

Цитата:
Сообщение от xu56857 Посмотреть сообщение
817 - оптопары в токовых датчиках работают вполне нормально. У Вас на схеме на оптопару после диодов резистор 10 Ом? Маловато будет, возможны ложные срабатывания.
Аналогично, использую 817, вполне работает и недорого )))

---------- Сообщение добавлено в 10:56 ---------- Предыдущие сообщение было в 10:53 ----------

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Оказывается, зетка филонит и делает пропуски, постоянной времени RC на выходе оптопары видимо не хватает их сгладить.
У себя сделал программную обвязку, чтобы исключить "дребезг контактов". Логика простая: режим "занято" устанавливается сразу, без паузы, а переход в режим "свободно" выполняется только если на последние Х мсек не поступало сигналов "занято". RC-цепочки на выходе оптопары отсутствуют.
__________________
Стройка
shalex на форуме   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 12:48   #38
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от xu56857 Посмотреть сообщение
У Вас на схеме на оптопару после диодов резистор 10 Ом? Маловато будет, возможны ложные срабатывания.
Ну не знаю, на местных модулях именно столько, и у них рс817, правда мостик другой... Я изначально хотел больше, но решил довериться профессионалам
Пока ложных не заметил (хотя ещё толком и не катал). Да и не должно их быть - датчики же токовые, нелинейные, есть нижний предел чувствительности, от обычных наводок не будут срабатывать.
Единственно, что плохо в 10 омах, так это с моими дополнительными диодами Шоттки - при к.з. напряжение будет больше и ток через оптопару может её спалить. Поэтому выпаяю парочку и посмотрю, хватит ли чувствительности, если нет - верну диоды и увеличу сопротивление.


Цитата:
Сообщение от shalex Посмотреть сообщение
RC-цепочки на выходе оптопары отсутствуют.
Мне этот вариант не совсем по душе - нужно слишком часто опрашивать входа, ведь можно первый раз (да и не раз) попасть на обратную полуволну и ничего не увидеть. А с аппаратной задержкой достаточно одного раза, по запросу.
Так что дело вкуса

Хотя соглашусь, программный способ дешевле. Но я по образованию не программист, а любитель, и привык где возможно решать железом
Eprinter вне форума   Вверх
Старый 17.04.2019, 13:13   #39
shalex
Местный
 
Регистрация: 08.07.2015
Адрес: Ступино
Сообщений: 2,394
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 3 раз(а) в 2 сообщениях
Сказал(а) спасибо: 3,824
Поблагодарили 2,280 раз(а) в 896 сообщениях
Репутация: репутация неоспорима (2281)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
и привык где возможно решать железом
Проблемы с полуволной, с программной фильтрацией, не замечал. Возможно потому что токовые датчики - они не импульсные, а статичные что-ли и нет смысла ловить от них именно импульсы, достаточно опрашивать в цикле, на мой взгляд. Безусловно, любой вариант годится, если он устраивает владельца/автора.

Еще не совсем понял историю с переполюсовкой - неужели при неудачной полярности DCC возникает очень много ложных срабатываний?
__________________
Стройка
shalex на форуме   Вверх
Старый 17.04.2019, 13:27   #40
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Если совсем нет задержки, то по закону подлости в самый ответственный момент можно несколько раз подряд пропустить полуволну нужной полярности. Поэтому надо либо ставить аппаратную задержку, либо опрашивать в несколько раз чаще, чем отдавать значение по запросу (который примерно 10 раз в секунду), и делать программную задержку.

Цитата:
Сообщение от shalex Посмотреть сообщение
неужели при неудачной полярности DCC возникает очень много ложных срабатываний?
Нет, наоборот - несрабатывания, буквально через раз. Но это только при старте зетки, там есть паузы одной полярности длиной 1.7мс, говорят под райлком. СтОит отправить любой лок в путь - паузы уменьшаются в несколько раз, и даже при его остановке не увеличиваются - в буфере уже есть команды, они и гоняются по кругу.
Eprinter вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 13:38   #41
shalex
Местный
 
Регистрация: 08.07.2015
Адрес: Ступино
Сообщений: 2,394
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 3 раз(а) в 2 сообщениях
Сказал(а) спасибо: 3,824
Поблагодарили 2,280 раз(а) в 896 сообщениях
Репутация: репутация неоспорима (2281)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Если совсем нет задержки, то по закону подлости в самый ответственный момент можно несколько раз подряд пропустить полуволну нужной полярности. Поэтому надо либо ставить аппаратную задержку, либо опрашивать в несколько раз чаще, чем отдавать значение по запросу (который примерно 10 раз в секунду), и делать программную задержку.
Повторюсь, пока такой проблемы не встречал на практике. Т.е. все отлично работает и без "железного" фильтра.

---------- Сообщение добавлено в 13:38 ---------- Предыдущие сообщение было в 13:35 ----------

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Нет, наоборот - несрабатывания, буквально через раз. Но это только при старте зетки, там есть паузы одной полярности длиной 1.7мс, говорят под райл
Эх, это еще хуже, чем ложные сработки. Ложные сработки просто остановят автоматику, а вот НЕсработки могут привести к физической аварии.
__________________
Стройка
shalex на форуме   Вверх
Старый 17.04.2019, 13:52   #42
xu56857
Пользователь
 
Аватар для xu56857
 
Регистрация: 02.02.2015
Адрес: Москва
Сообщений: 597
Сказал(а) 'не согласен(а)'!: 5
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 2,539
Поблагодарили 2,264 раз(а) в 399 сообщениях
Репутация: репутация неоспорима (2279)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Пока ложных не заметил (хотя ещё толком и не катал).
"Пробивает" через балласт . Ставил резисторы 22 Ом, периодически замечал срабатывания датчика ( S88 шина , схема датчика , как и у Вас , с RC цепочкой. Подтягивающий резистор 47 кОм, конд. 2,2 мкф) , заменил резисторы на 150 Ом, все стало отлично.
А RC цепочка , имхо, нужна. Посмотрите осциллографом какой сигнал на выходе оптопары - сразу захочется ее поставить. Хотя работает и без нее.
Диодные мосты ставил DB107 и 2w10 .
xu56857 вне форума   Вверх
3 пользователя(ей) сказали cпасибо:
Старый 17.04.2019, 22:38   #43
laba
Местный
 
Аватар для laba
 
Регистрация: 06.03.2009
Адрес: Питер
Сообщений: 3,585
Сказал(а) 'не согласен(а)'!: 9
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 6,642
Поблагодарили 4,652 раз(а) в 1,766 сообщениях
Репутация: репутация неоспорима (4920)
По умолчанию

У меня стоят резисторы 270-300 Ом, в связке с мостиками. Проблем с ложными срабатываниями не имел. Токовый датчик отлавливает различные типы нагрузок, без проблем. Разве что вагоны с резистором на колпаре не пробовал, т.к. пока нет таких.
Тоже использую PC817 и DB107(2W10). RC цепочка, на выходе оптопары, присутствует.
__________________
HO, цифра, OpenDCC, S-88N, OpenCar, BiDiB
С приветом из подземки!!!
laba вне форума   Вверх
Пользователь сказал cпасибо:
Старый 17.04.2019, 23:36   #44
shalex
Местный
 
Регистрация: 08.07.2015
Адрес: Ступино
Сообщений: 2,394
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 3 раз(а) в 2 сообщениях
Сказал(а) спасибо: 3,824
Поблагодарили 2,280 раз(а) в 896 сообщениях
Репутация: репутация неоспорима (2281)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Нет, наоборот - несрабатывания, буквально через раз. Но это только при старте зетки, там есть паузы одной полярности длиной 1.7мс, говорят под райлком. СтОит отправить любой лок в путь - паузы уменьшаются в несколько раз, и даже при его остановке не увеличиваются - в буфере уже есть команды, они и гоняются по кругу.
Кстати, вспомнил один момент о ложных срабатываниях, когда лок одновременно на токовом участке, который подключен через модуль ОС, и на участке, который подключен напрямую к бустеру.

Второй вариант в том же "стиле" - проверить, нет ли контакта между рельсом "через модуль ОС" и рельсами от бустера напрямую. Если есть, то оба рельса изолировать.
__________________
Стройка
shalex на форуме   Вверх
Старый 11.05.2019, 16:26   #45
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Переключил сигналы на всех FB-2 от МД, перевернул сигнал DCC, теперь все модули ОС при включении зетки работают без дёргаганья. Длинная пауза инвертировалась в импульс:


Зато потерял пару часов, разбираясь, почему перестал работать стрелочный декодер на дуалине - от МДпрог работает стабильно, от зетки же сработка с десятой или более команды, затем зависает наглухо, после перезагрузки опять тупит. В конце концов догадался перевернуть сигнал и на него, заработал. Видимо, библиотека DCC от MynaBay, которую я использовал, сбоит из-за этого длинного импульса.

Жгуты проводов к сервам ушли, вместо них теперь пара аккуратных шлейфов:


Под макетом после раскидывания плат РСА9685 тоже стало культурнее, только одна серва подключена через удлинитель, остальным хватило штатных "хвостов":




Вот такая плата токовых датчиков на МСР23017 получилась:


Травилась вместе с двумя платами под будущие датчики положения стрелок:



При наладке словил массу неожиданных глюков - несколько SMD-конденсаторов кряду оказались частично пробитыми, показывалась постоянная сработка токовых датчиков:


Особенно доставил 10мкФ по питанию - имел сопротивление меньше ома, из-за него накрылся стабилизатор на ардуинке Теперь буду все проверять до и после пайки. Хотя прозванивал же тестером перед включением, не было нигде пробоя, а после подачи питания посыпались, причём по очереди...
Eprinter вне форума   Вверх
6 пользователя(ей) сказали cпасибо:
Старый 11.05.2019, 18:35   #46
Alexmit
Местный
 
Регистрация: 29.06.2010
Адрес: Москва
Сообщений: 1,719
Сказал(а) 'не согласен(а)'!: 3
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 550
Поблагодарили 1,633 раз(а) в 942 сообщениях
Репутация: обеспечил(а) себе прекрасное будущее (1633)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
При наладке словил массу неожиданных глюков - несколько SMD-конденсаторов кряду оказались частично пробитыми, показывалась постоянная сработка токовых датчиков:
И таких номиналов в схеме задержки хватает для нормальной работы?
Я у себя увеличил задержку до 2 сек. (было 0,043 с ) И то контрольный светодиод подмигивал.
Alexmit вне форума   Вверх
Пользователь сказал cпасибо:
Старый 12.05.2019, 00:18   #47
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от Alexmit Посмотреть сообщение
И таких номиналов в схеме задержки хватает для нормальной работы?
Да собственно до нормальной работы всё никак не дойду Выяснилось например, что надо таки разлочивать зетку, не пропускает команды от программы управления, только с рокомышки. А при подключении через рокобас не проходят сигналы с новой платы ОС. Хочу сначала выжать максимум из залоченной, есть некий спортивный интерес Всё равно ещё много работы на макете предстоит сделать, прежде чем приступать к программированию.

Номиналы RC подогнал к местным модулям, чтобы были близкие временные значения. Те тоже моргают часто из-за плохого контакта, но первое срабатывание чёткое, а дальше уже зависит от логики программы управления. Рокрейлу этого достаточно, триггер занятости защёлкивается и освобождается только при занятии следующего блок-участка.
Постоянная времени превышает интервал опроса датчиков, это главное, так что если надо будет увеличить задержку, то можно будет ничего не перепаивать, организовать программно, как у Александра.
Eprinter вне форума   Вверх
Пользователь сказал cпасибо:
Старый 12.05.2019, 11:36   #48
Alexmit
Местный
 
Регистрация: 29.06.2010
Адрес: Москва
Сообщений: 1,719
Сказал(а) 'не согласен(а)'!: 3
Сказали 'не согласен'! 1 раз в 1 сообщении
Сказал(а) спасибо: 550
Поблагодарили 1,633 раз(а) в 942 сообщениях
Репутация: обеспечил(а) себе прекрасное будущее (1633)
По умолчанию

Цитата:
Сообщение от Eprinter Посмотреть сообщение
Те тоже моргают часто из-за плохого контакта, но первое срабатывание чёткое, а дальше уже зависит от логики программы управления.
Но меня раздражает. Локомотив едет по участку, а оттуда: ON, OFF, ON, OFF, ON, OFF.
Alexmit вне форума   Вверх
Старый 14.05.2019, 05:55   #49
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Цитата:
Сообщение от Saddam Посмотреть сообщение
отключите и проверьте паузы уйдут
Да, так и есть:

Произвёл контрольный выстрел, так сказать

Цитата:
Сообщение от Eprinter Посмотреть сообщение
при подключении через рокобас не проходят сигналы с новой платы ОС
Хе-хе, победил проблему
Оказалась элементарной - Рокобас слал на модули запрос, отличный от стандартного запроса зетки. Отличался второй байт, вместо 0xFC посылается 0xFB. Естественно, мой модуль ОС к этому был не готов. Внёс небольшую правку и всё заработало:
Код:
if (XNetMsg[0] == ModC2 && (XNetMsg[2] == 0xFC || XNetMsg[2] == 0xFB) && XNetMsg[3] == group)
Вот такие диграммы пришлось снять, чтобы разобраться:


Верхняя пара - шина R-BUS и выход на СОМ-порт, модуль Рокобас загружен программой Фидбэк.
Средняя пара - шина X-BUS и выход на СОМ-порт, модуль Рокобас в своём прямом амплуа. Видно, что он не получает ответы не только от модуля на ардуине, но и от FB2 с адресом 2.
Нижняя диаграмма - шина X-BUS после внесения правки в программу модуля на ардуине.

Огромное спасибо энтузиасту Jindra Fučík, благодаря его описанию интерфейса проблема решилась в разы быстрее.

Почему в режиме рокобас потерялся родной модуль фидбэка, надо разбираться.
ПС Разобрался - каким-то неведомым образом у этого модуля сменился адрес на шине, с 2 на 24. Вероятно, случайная комбинация на шине, когда тыкал разъёмы туда-сюда. Иногда ружьё стреляет само

Последний раз редактировалось Eprinter; 14.05.2019 в 07:27.
Eprinter вне форума   Вверх
3 пользователя(ей) сказали cпасибо:
Старый 16.05.2019, 11:40   #50
Eprinter
Заглянувший
 
Аватар для Eprinter
 
Регистрация: 27.02.2017
Адрес: Нашенский
Сообщений: 113
Сказал(а) 'не согласен(а)'!: 0
Сказали 'не согласен'! 0 раз(а) в 0 сообщениях
Сказал(а) спасибо: 252
Поблагодарили 279 раз(а) в 68 сообщениях
Репутация: как роза среди колючек (279)
По умолчанию

Приболел, три дня дома, естественно с пользой.
Прочувствовал, что означает поговорка "когда не знал, да ещё и забыл..."
В общем, немного стала понятнее логика работы Рокрэйла. До того немного разбирался полтора года назад, тогда автоматизация охватывала только основные пути плюс два тупика. Теперь работаем везде.

Вчера два лока в автохаосе больше часа нормально ездили, без сбоев. И дуокодер, и модуль ОС на 40 датчиков вели себя достойно.
Сегодня добавил ещё один и опа - два лока стартуют, третий стоит. Блок назначения высвечивается, скорость задаётся, свет горит, стрелки переключены. Случайным образом, любой из имеющихся.
Берём рокомышь, вручную задаём этому локу скорость, он доезжает до заданного пункта и дальше уже подхватывается программой, управляются все три автоматом.
Правда, продолжается идиллия недолго - то ли где-то какой-то датчик ОС программа не увидела, то ли на лок команда не проходит, и всё сбивается.
Пробовал раз 10. Перегружался раз 30.

ПС Запустил два лока, отошёл. 10 минут поездили, смотрю - один лок стоит. Те же симптомы - маршрут построен, скорость задана, на рокомышке символ лока моргает, но ещё дополнительно горит "пауза". Что-то вне зоны моего понимания...

ПСПС И опять - лок упёрся лбом в тупик, колёса крутятся. Датчик сработал. Команда на стоп дана. Очнулся спустя секунд 5, когда простроился обратный маршрут и пришла команда ехать взад. Потеря пакетов? Они что, зеткой редко повторяются?
Код:
21:46:05 loc 4 velocity=11 direction=fwd
21:46:05 turnout 1 1 straight
21:45:48 loc 4 velocity=7 direction=fwd
21:45:41 loc 4 velocity=11 direction=fwd
21:45:41 turnout 16 3 turnout
21:45:40 loc 4 velocity=7 direction=fwd
21:45:40 turnout 9 4 straight
21:45:38 loc 6 velocity=5 direction=rev - на мышке однако пауза, видимо Рокобас пропускает
21:45:38 turnout 9 3 straight

До того, как я недавно поменял прошивку зетки, нормально запускались все три. Она у меня до сих пор залоченная, подключена через Рокобас. Другого объяснения на ум не приходит. Немного поэкспериментирую и куплю код, начинает надоедать.

Ещё два раза менялись адреса у разных FB2. Надо видимо скачать предыдущую прошивку, где нет возможности настраивать адрес по шине. Конкретно напрягает - тут с программой кое-как разбираешься, и ещё вдруг пропадают датчики...

=====

И немного фот. Модернизация стрелки:


Постоянно сходили вагоны, когда проезжаешь на отклонение. В автомате там разъезд на две однопутки, въезд только прямо, а уже выезд с отклонения, всё нормально было. Решил доработать, напаял кусочек проволочки, теперь реборда не закатывается на остряк. Позже выяснилось, что там основную роль играл перекос винтом между плоскостью стрелки и заездом. Меньше миллиметра, а хватало. Устранил и его.

Вот так крепятся сервы:


"Колхоз" зигзагом только на одной, она слишком близко к краю выходила, боялся повредить. Загибы для смягчения нагрузки, пружинят и позволяют настроить с небольшим запасом.
Там же рядом и один из расцепителей:


Как раз под ним ребро жёсткости, пришлось немного извратиться.

Чтобы всё это проделать, нужно было выдвинуть макет на середину, тогда открывается отличный доступ к тыловым сторонам:

Последний раз редактировалось Eprinter; 16.05.2019 в 14:48.
Eprinter вне форума   Вверх
13 пользователя(ей) сказали cпасибо:
Ответ

Опции темы
Опции просмотра

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.

Быстрый переход

Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Мой первый макет НО andreas Наши стройки 4 15.06.2017 21:48
Первый макет Paravoz Проектирование 18 30.04.2014 14:14
Мой первый макет H0 BasicShared Проектирование 21 29.04.2014 01:39
Первый макет H0 Saddam Проектирование 52 03.10.2013 19:09
Первый макет. Mr Gorsky ЧАВО 24 22.11.2012 09:04


Текущее время: 16:18. Часовой пояс GMT +3.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc. Перевод: zCarot
Copyright © ModelldepO.ru 2006 -